KTM Owners Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Brought my self the bike a few weeks ago, 2011 duke 125 with 13k on the clock. after riding it i noticed when i use my front brake it gives a pulsating feeling and the front of the bike moves up and down quite noticeably. ive have the rotor checked and cleaned the caliper and rotor, all bearings are fine. Its most noticeable from 20mph and slower.
I think it could be the abs sensor malfunctioning, if so is there anyway of disabling it to test? or any other suggestions on what might be causing the issue
Thanks
 

·
Premium Member
Joined
·
31,505 Posts
I also think its a bent disc.

To disable the abs just move the sensor away a bit.
 

·
Registered
Joined
·
7,104 Posts
ive had the disc checked and it all looks fine
How did you check it? Best do it with a pencil or marker while the front wheel is lifted...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
How did you check it? Best do it with a pencil or marker while the front wheel is lifted...
I got the front end on a paddock stand and used a screwdriver against the disc while spinning the wheel around to see if it catches or moves away from tip
 

·
Premium Member
Joined
·
31,505 Posts
Try cleaning the disc with a scotchbrite pad (green pad scourer from supermarket) and brake cleaner. Also rub the pads on a concrete kerb to deglaze while you are at it.
 

·
Registered
Joined
·
7,104 Posts
I got the front end on a paddock stand and used a screwdriver against the disc while spinning the wheel around to see if it catches or moves away from tip
Ok, that works too... if Kev's hints dont work make sure the pistons move and try new pads.
 
1 - 8 of 8 Posts
Top