KTM Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey, looking for some advice for an issue that developed on my bike. Went out yesterday for a blast and things were great, until I stupidly over estimated the amount of fuel I had in the tank.... yep ran out half way from anyway. After pushing the bike for a mile or so managed to convince a farmer I’d passed to give me a couple of litres of fuel.... cost me a tenner 🤦‍♂️ (who said farmers were poor) anyway, found a garage and carried on my way. 40 minutes or so later the bike started spluttering, regardless of speed or gearing progressively got worse the longer I left it. Stopped, and restarted the bike, problem gone..... 10 minutes later, same thing again, repeated the process over and over again until I got home. The last stint home was at a gentle pace and the issue didn’t return, naturally I’ve checked the inline filter and it looked clean, but before I start stripping the bike, has anybody had this issue before? either way any ideas on what I should be checking??
Cheers
 

·
Premium Member
Joined
·
7,324 Posts
Stale shitty farmers petrol, probably mixed with a bit of red diesel.

Just run some fresh fuel through it and see what happens.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I did think that, but I thought with the amount of fresh fuel from the garage it wouldn’t have caused any real issues.... guess I was wrong🤦‍♂️
 

·
Premium Member
Joined
·
7,324 Posts
After that, try a new plug / plug cap ..... they can cause problems after 30hrs.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Update..... drained the tank, replaced the filters. Problem is now permanent. Replaced the spark plug and cap, no improvement.
Any ideas?
 
1 - 7 of 7 Posts
Top