KTM Owners Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hi,

I've got a 2017 500 EXC that I've not used in a while. It now won't turn over at all. Points I have looked at:

Battery charged, tried a spare, tried jumping from another bike and also using a lithium jump pack.

When hitting the starter button a very minor click can be heard from the starter relay, but not always. No where near as loud as a relay would normally sound when switching.

Taking the relay off and activating it from 12v works, so there is a circuit across the large poles.

Bridging the poles does nothing, not even a spark

Bridging the spade terminals on the relay, as if switched on by the handlebar switch does nothing.


The starter switch on the bars is working, have tested with meter.

The ground is good and there is continuity to the outside of the starter.

There is continuity from end to end on the starter positive

I've disconnected the kill switch/combo switch to eliminate that.

I've not played with the run/dont run switch. But I think it would have turned over if that was set to off.

All fuses are tested ok, on the relay and in the rubber fuse box.

The tip over switch seems ok, in that you can hear the ball rattle in it

I'm a bit stuck for ideas now and hope someone here might have an idea.

.

Thanks,

Ben
 

·
Registered
Joined
·
22 Posts
Discussion Starter #2
After a few hours of checking all of the above I just cleaned up the already very clean ground cable to subframe connection with some sandpaper, installed an additional washer to give it some more grip and it fired right up. Kicking myself as it looked and felt perfect but actually redoing it sorted it.
 
1 - 2 of 2 Posts
Top