KTM Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
Took the 640 Adventure over to Wales at the weekend, and spent Saturday out with Gordo on some 'lanes.

Bike performed very well for the most part but developed some interesting running problems.

First manifested itself as stalling when allowing the revs to drop to idle, but would start and idle fine, and pick up no problem on the throttle. This happened for about half an hour. That seemed to clear itself, but in return I was given a 3000rpm idle speed.

Also, on the way home, I ran out of fuel. Put the tank onto reserve and got about 100yards before it died again. Filled the tank, she ran fine till I got home (apart from the fast idle that is)

I suspect the out-of-fuel issue might be a dodgy fuel pump, but could that also cause the strange running problems and fast idle?
 

·
Registered
Joined
·
57 Posts
After you filled it up, did you run it with the fuel tap on main or reserve? I used to have a tank that let in a bit of water, run it on reserve and all it got was water (water being heavier than petrol)
Poor idling sounds like crud in the pilot jet to me (but does not explain fast idle)
Can you not see if your pump is working, do you have a visible fuel filter?

I suggest a full carb clean!
 

·
Registered
Joined
·
2,785 Posts
Water in the fuel you say...?


:)
 

·
Registered
Joined
·
66 Posts
Discussion Starter #4
hmm would certainly explain the fuel issue, but not the fast idling.

I'll probably take it all off and have a look anyway
 
1 - 4 of 4 Posts
Top