KTM Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
Hi all,

Familiar problems with my 660, but this time a little bit different. It'll start first kick from cold with choke and first kick from hot. The issue is when it's been run for 2-3 minutes or so then cuts out and and has to be restarted - the bastard just won't go! I stood for 20 minutes trying to start it this morning after it cut out on the driveway, I eventually had no choice but to give up!

Has anyone else had this problem? Is there something obvious that I'm missing?

Thanks in advance.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #3
I haven't tested the coil, thanks for the pointer. Will test it soon. Would a dodgy coil result in the problems I'm having? I'd have thought it wouldn't start at all if it was on its way out.
 

·
Registered
Joined
·
263 Posts
PPW
After you've checked out the coil. Have a think about the carb.
Your problem sounds a bit like mine that I've been struggling with for a long time.
I couldn't get a tick over and struggled to start it without the choke. I narrowed it down to the idle circuit in the carb. Still haven't got to the bottom of it but just fitted a new carb tonight and that fixed it.
I'll keep looking at the old carb and if I find something - you can try a swap over. Do you have an ultrasonic cleaner suitable for a carb at your work?
Not got much on just now (mine is running sweet and no real jobs outstanding just now:smokin:) so give me a shout if I can help.

Raymond
 
1 - 7 of 7 Posts
Top