KTM Owners Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
15,275 Posts
Discussion Starter #1
Changed the oil on the new girl last night, new filter, oil screens, gaskets, washers, the full shebang. Put 2.5 litres of oil in and it still isn't registering on the level ??? is it becuase the new filter has soaked some of it up ???

Obviously don't want to over fill it ! ! !
 

·
Registered
Joined
·
1,878 Posts
dont forget to make sure the oil is warm before deciding on the level
 
  • Like
Reactions: DavidS

·
Registered
Joined
·
5,561 Posts
For what its worth, some manuals had 2.5L printed - which is a mistake. I think it should be ~3.5 with a filter change...
 

·
Registered
Joined
·
1,400 Posts
Mmmm, according to my owners manual it says approx. 3.0 litres /(0.8 USgal) during oil/filter change
 

·
Registered
Joined
·
1,400 Posts
Can you run 10w50 full synth in these?
From my 06 manual, so yes you can

Engine oil
Only use fully synthetic engine oils that meet
the JASO MA quality requirements (see infor-
mation on the can).
KTM recommends Motorex Power Synt 4T in
the 10W/50 viscosity (for temperatures over
0°C, 32°F) or 5W/40 (for temperatures under
0°C, 32°F).
 

·
Registered
Joined
·
6,024 Posts
That is all you are supposed to use
 

·
Registered
Joined
·
11 Posts
Hello.

I just need to take a look at my filter but access seems to be blocked off by a few hoses. I don't see any info on this in any manual or online.
 

·
Premium Member
Joined
·
7,914 Posts
The access might appear to be slightly 'blocked off' but the hoses will nudge out of the way enough to allow the cover to be removed and for the dilter to be removed. If you havent done this before, then you will find circlip pliers will make removal of the filter easier (or normal pliers put in and opened out to grip side od filter indent) look for o ring on inside of cap / in recess of case. Thia will be required when putting back together. The bolts are only (iirc) 6nm so dont mess the thread. If filter is wavy, this will confirm your oil pressure problem from other posting (waterpump etc etc)
 

·
Registered
Joined
·
11 Posts
You do realise this thread is ten years old?
Ha ha... Yeah... you guys are all Pharaohs having these bikes 10 years ago. I'm just catching up now... Finally affordable. 2006? Shite... that's like yesterday. I feel like i have a bran new Porsche... uhm... but something went wrong... but that happens to folks with 2020s too. So... shit happens anywhere, anytime. Hopefully I get sorted soon before the Apocalypse on the horizon...
 

·
Registered
Joined
·
238 Posts
Yep, disregard my remark, the same issues will arise ten years later and fortunately the same solutions will also apply.
Good luck and enjoy the ride.
 

·
Registered
Joined
·
11 Posts
If I remove this hose i'll drain a bunch of oil? My oil colour doesn't look that bad though...


35707
35708
 
1 - 20 of 22 Posts
Top