KTM Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!
1 - 15 of 15 Posts

·
Registered
Joined
·
1,215 Posts
Discussion Starter · #1 ·
My 990 has always started up easily from cold, first press of the button normally, but since last week it seems to take ages before it fires up. Only when it’s stone cold, once it’s warm it’s fine for the rest of the day.
New battery last year, only change is a 2 into 1 exhaust, otherwise it’s the same as before.
At first I thought it might be old fuel as it had sat for a month, but after riding to the North Wales rally this weekend and sticking a few tanks full of fuel through it hasn’t improved.
Hoping someone can give me a few pointers?

Goose
 

·
Registered
Joined
·
1,215 Posts
Discussion Starter · #4 ·
Spins fast, no lights on the dash, no click, just like there’s no fuel. Then it eventually starts and it’s fine.
Perhaps filter? No idea.
 

·
Registered
Joined
·
3,163 Posts
When it starts does it fire both cylinders and run fine or starts lumpy and then clears?
 

·
Premium Member
Joined
·
31,547 Posts
Temperature sensor? Is the temperature display on the dash making sense?

If it was the filter it would not rev.
 

·
Registered
Joined
·
550 Posts
The 950's have a heating element on the carb for those cold and frosty morning starts
Do the 990 have a similar set up.
 

·
Registered
Joined
·
1,215 Posts
Discussion Starter · #13 ·
Temperature sensor? Is the temperature display on the dash making sense?

If it was the filter it would not rev.
Yes that’s all fine, fitted a new thermostat last year, when it had new Brisk plugs, fuel filter etc.

Need to get over to you sometime for a map, will message you to arrange.
 

·
Registered
Joined
·
1 Posts
Yes that’s all fine, fitted a new thermostat last year, when it had new Brisk plugs, fuel filter etc.

Need to get over to you sometime for a map, will message you to arrange.
Hey, it's been a while since this thread was live but I thought I give it a try... I'm having the exact same problem on my 2012 990 Adventure. Hard to start when cold, after that all is good. Did you find a solution for the problem? Any info would be much appreciated!
 

·
Registered
Joined
·
2,627 Posts
Has the bike been standing? Old fuel and shit in the tank....fuel filter in left hand tank may need seeing too.
Is it spinning over okay or sluggish.....battery etc. Start with the simple, open filler caps and make sure all petcocks are open.
 
1 - 15 of 15 Posts
Top