KTM Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 17 of 17 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Hey everyone,

I'm now well into the 950, using it every day (even in the snow :) ) but i've come across a couple of issues and wonder if any of you more experienced types might now of the cause....

First off, neutral light.... it seems to flicker on and off at will so i cant leave the bike to warm up on the side stand. Is this common, is there a simple fix?

Secondly, she seems to cut out when sat at traffic lights a hell of a lot.
She'll ride along fine with no problems at all but as soon as you stop she'll just die like the kill switch has been hit??? (its not that btw)

Any help would be much appreciated :redface:

Phil
 

·
Registered
Joined
·
44 Posts
Discussion Starter #3
What is and where will i find the standby switch?
 

·
Registered
Joined
·
388 Posts
oops, sorry I meant the side stand switch!
(I've just come in from work where I deal with electrical products! )
 

·
Registered
Joined
·
345 Posts
Make sure the idle speed is set between 1400 - 1500, might be a cause of the cutting out if its too low.
 

·
Registered
Joined
·
7,273 Posts
There's an idle control tucked in the fairing on the left hand side (as you're sat on the bike) it's black and you can alter the revs at idle, make sure it's warm before you start altering it.

Not sure about the neutral light though, have you posted the same Q over on ADVrider? If not it might be worthwhile.
 

·
Registered
Joined
·
41 Posts
I have similar problem KTM 950 Adventure 2005 19000 miles recent service at KTM dealer. The bike died twice on the traffic lights whilst ideling? And on some occasions the rev keep jumping 1200 - 1900 ish.

When the bike was in garage no smell but now when riding done over 60 miles over night i can smell petrol smell in garage but i cant see any leakage?

I am confused tooo
 

·
Registered
Joined
·
5,600 Posts
Hey everyone,

I'm now well into the 950, using it every day (even in the snow :) ) but i've come across a couple of issues and wonder if any of you more experienced types might now of the cause....

First off, neutral light.... it seems to flicker on and off at will so i cant leave the bike to warm up on the side stand. Is this common, is there a simple fix?

Secondly, she seems to cut out when sat at traffic lights a hell of a lot.
She'll ride along fine with no problems at all but as soon as you stop she'll just die like the kill switch has been hit??? (its not that btw)

Any help would be much appreciated :redface:

Phil
Neutral light switch sounds a bit like mine - if it is then there may be a very 'simple' fix - watch this thread http://www.ktmforum.co.uk/adventure/67562-my-baby-open-heart-surgery-next-week.html
 

·
Registered
Joined
·
2,608 Posts
Hey everyone,

Secondly, she seems to cut out when sat at traffic lights a hell of a lot.
She'll ride along fine with no problems at all but as soon as you stop she'll just die like the kill switch has been hit??? (its not that btw)

Any help would be much appreciated :redface:

Phil
It could be your fuel tanks, are the vent holes ok, Does this happen more after a fill up? If it does cut out at the lights again after a fill up, open and close the fillers. Just a thought.
 

·
Registered
Joined
·
289 Posts
During the first week of ownership my 2004 950 did exactly the same. I speeded up the tickover, (L Hand side just behind the perol tank) and it now happens very rarely
 

·
Registered
Joined
·
44 Posts
Discussion Starter #12
Thanks very much guys, I will give the idle control a bash and have a look into the side stand switch :)
 

·
Registered
Joined
·
124 Posts

·
Registered
Joined
·
5,600 Posts
Being the new owner of Mr Woo's 950 the problem is now mine! I have read about your "heart surgery" and think I would prefer the simple quick fix!! Is ther one? or should I just bypass the side stand and do without a neutral light? :)
You may b able to get away with bypassing the neutral light switch on the 950 - it does open up the possibility of riding off with the sidestand down though................

On the 990 I understand the FI mapping is different in the lower gears - so if the bike does not know what gear it is in it may not run quite right !

If you want I can take some photos of the offending part so you can see what you are working with.
 

·
Registered
Joined
·
124 Posts
That would be good...thanks, going to have a good look at it and strip and clean what I can first to see if that does any good? The neutral light does come on if I apply a little pressure on the pedal, but as soon as the pedal is lifted off it goes out and the bike cuts out as soon as I put the sidestand down.
 

·
Registered
Joined
·
124 Posts
How lucky am I....!!!

I took off the side stand and undid the cover to the offending item, I could see that the contacts on the back of the cover looked a bit dirty and worn so rubbed over them lightly with a bit of wet and dry and then sprayed with contact cleaner, put it all back, it was better but still did not engage the neutral light all the time, so I took it apart again and had a look at the small stud (mine only has one) that is in the barrel, I took this out and found it has a spring behind it, so I stretched the spring just a little bit and then put it all back together again...........IT WORKS!!!
 

·
Registered
Joined
·
548 Posts
HI I have a rc8 with a similar problem, when i start the bike up it runs for about 12mins, neutral light flickers then neutral light goes out and engine cuts out.Then I tried bike on paddock stand with side stand up neutral light flickers again then goes out but engine still runs:confused:Do you think this would be some thing to do with the side stand switch cheers:)
 
1 - 17 of 17 Posts
Top