KTM Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Just purchased a duke 2 with only 2300 miles.

I have noticed two issues

1. Rev counter sometimes drops off to zero when blipping the throttle.

2. Indicators flash quicker when revs increased.

Was thinking potential reg/rec issue but it does not effect headlights or rear light brightness
Battery voltage is 12.5v ish rising to 13.5 ish on tickover then rising to 14.5 ish at higher revs

So I’m thinking it could be a flasher relay???
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Battery appears ok, generator is generating so thinking voltage control or flasher unit (as other lights don’t seem effected)
 

·
Registered
Joined
·
355 Posts
possibly a ground/earthing or loose connection item for the flasher.
have a Duke 1 620 1994 and doesn't do that what you mention. another possibility is the mechanism inside has vibrated loose.
voltages should not exceed 15V. if it does the RR is fooked, if it don't check the wiring of the alternator: all 3 alternator wires should not have conductance to ground, but around 0,3 to 0,8ohm resistance between each other. alternating voltage should be minimum 35Vac, and between 12,5 and 14.8Vdc (at the battery).
the speedo does go wavy at higher speeds (140+ kmph) but the revcounter stay nice and smooth.

the revcounter gets its puls from the alternator (one of the yellow wires has a splice from the RR connector that goes to the counter).
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Cheers I’ll bear that in mind!
I’ve found a broken wire now on the back of the fuse box which supplies the indicators so I’ll remake that then see what happens before I dig any deeper
 
1 - 6 of 6 Posts
Top