KTM Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi all, Gaz here, my rear light aint working at all on my EXC 200, the front one is, can anyone help me please????????
 

·
Premium Member
Joined
·
31,489 Posts
What year bike? The bulb holder possibly has a bad earth. Easiest cure is one on my LED conversions for £10 :)
 

·
Premium Member
Joined
·
31,489 Posts
Unplug the rear light loom (unplugs above air filter), remove the black plastic number plate carrier, pull the loom out of the airbox and remove the lens. Remove the loom off the number plate carrier and chop off the bulb holder.

Post the loom and a tenner to me and I'll get it straight back to you.

When you receive it back you will see there is a short length of foam tube. This goes around the bulb base and is trapped by the lens to keep it secure and keep water out.
 

·
Registered
Joined
·
308 Posts
Unplug the rear light loom (unplugs above air filter), remove the black plastic number plate carrier, pull the loom out of the airbox and remove the lens. Remove the loom off the number plate carrier and chop off the bulb holder.

Post the loom and a tenner to me and I'll get it straight back to you.

When you receive it back you will see there is a short length of foam tube. This goes around the bulb base and is trapped by the lens to keep it secure and keep water out.
hi mate have you got any replacement light units for my 2009 exc as mine has stopped working thx
 

·
Registered
Joined
·
308 Posts
hi mate have you got any replacement light units for my 2009 exc as mine has stopped working thx
rear tail light
 
1 - 7 of 7 Posts
Top