KTM Owners Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
2,306 Posts
Discussion Starter #1
I'm having more and more issues with my gearbox lately...jumping out of gear, false neutrals and so on.

Thinking of making use of my extended KTM warranty...in how far is KTM willing to admit they've made a mess of even the updated RC8 gearbox. Read that the 2011 gearbox is absolute 100% spot on...can this be build inside ol'timer RC8's with no R.
Gear box is a casette type so installment shouldn't be that much work imo.
 

·
Registered
Joined
·
2,306 Posts
Discussion Starter #2
oh yea got 20000km on board in 2y
 

·
Registered
Joined
·
7,985 Posts
how far is KTM willing to admit they've made a mess of even the updated RC8 gearbox
You've more chance of a blow job from Angelina Jolie :rotflmao:

As per Bear's comment, Dre's been posting loads of info on improving the shift with the Oberon slave cylinder and Sato shift spindle mounting if you're having problems. Personally, I don't think the issue is the gearbox itself, but with getting the gear engaged properly in the first place.
 

·
Registered
Joined
·
6,642 Posts
If you flick it into the next gear without clutch, does it catch every time? If not, consider the gearbox, otherwise check for air, lever play and slave cylinder.
 

·
Registered
Joined
·
2,306 Posts
Discussion Starter #6
Its still oem master-slave clutch set and yes it flips out of gear while acclerating without clutch usage.
 

·
Registered
Joined
·
6,642 Posts
Weren't you talking about lever sensors in another post?
 

·
Registered
Joined
·
1,727 Posts
I have about 27.000km, most on road but many on track, stock master-slave, never replaced the clutch fluids and never had I any issues
 

·
Registered
Joined
·
7,985 Posts
I have about 27.000km, most on road but many on track, stock master-slave, never replaced the clutch fluids and never had I any issues
I haven't had any issues either (apart from appetite for clutch plates) since fitting the Powerpart rearsets. Are you still on your original plates mate?
 

·
Registered
Joined
·
7,985 Posts
Good going! :D
 

·
Registered
Joined
·
6,642 Posts
so clutch it up then next time! :burnout:
 

·
Registered
Joined
·
2,306 Posts
Discussion Starter #14
Weren't you talking about lever sensors in another post?
yep, but nothing to do with that, gi mounting sensor...no bazaa plug in-out stuff, bit homemade stuff.

Recieved your b6ap?
 

·
Registered
Joined
·
6,642 Posts
Home made may work as well. B6AP plug received. Still waiting for the wire to arrive from Austria as well as the OBD2 interface. Then hook it all up to the dash and start programming! :D
 

·
Registered
Joined
·
2,306 Posts
Discussion Starter #16
went for a spin for west-coast today , apart from lorries falling from bridges just happening behind my back, it must be the clutch indeed, did some test with pazzo levers distance, very on-off feeling and it grabs.

Had a nice day, sun was shinning, coppers were busy with closed highway and cleaning up the mess.
Besides the tube from expansion to radiator jumped out and made some mess also.
Just one of those days on an RC8.
 
  • Like
Reactions: Fat Tony

·
Registered
Joined
·
2,306 Posts
Discussion Starter #17
Ordered an oberon slave clutch, some guys I known overhere are the benelux importers it seems, didn't knew that
...still not certain what colour to pick red or orange.
 

·
Registered
Joined
·
2,306 Posts
Discussion Starter #18
Weren't you talking about lever sensors in another post?
yea busy with this thing here...still an experiment so don't mind the boults


that rear plate is IKEA material, sensors are magnetic detectors, a magnet attached to gear lever in combi with counter, so it can count up and down, have some problems with neutral black green wire can't read voltage from that one...set it on hold for now, spend whole wednesday afternoon already and wetter is to nice for such things.
 

·
Registered
Joined
·
2,306 Posts
Discussion Starter #19
this one jumped out, prob. hooked it up when i removed my fairing the other day
 
1 - 19 of 19 Posts
Top