KTM Owners Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Attempted to put steering lock on bike.... Pressed and held Race Key Button and yellow light came on but steering lock didn't engage?

Now bike ignition/display won't come on when Race Key button pressed??

Any ideas please?

Many thanks
 

·
Registered
Joined
·
17 Posts
Not sure on every model year but my SAS 2020 steering antenna is on the left side of the steering

Maybe try to get the remote closer? Low remote battery... I know you might already look I guess

Envoyé de mon SM-G950W en utilisant Tapatalk
 

·
Registered
Joined
·
80 Posts
There should be a symbol on the left side of the dash that shows you where to hold the key in case the battery in the key is low.

I had this once. Turned out it was because a Mercedes with keyless had parked right next to my bike and it was interfering. Couldn't push bike away as steering lock was on! Kept trying and it eventually switched on while I was on hold to KTM breakdown! Ironically it was about half an hour after I picked it up from its first service. Thought maybe they'd forgotten to tighten battery cable or something at first as it did nothing.

The number of flashes the light on the dash does is actually a code. Don't know the error codes though I'm afraid.

Cheers

Daz
 

·
Registered
Joined
·
497 Posts
Try pressing the button for variable periods of time starting from momentary to a few seconds. Whilst I've no idea if it helps I take the pressure off the steering lock when I press the button. Failing that, do as Soso2565 suggests and hold the key close to the antenna when pressing the button.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #6
Hi, the steering lock didn't engage when the button was pressed.... So steering is un-locked. Have left bike alone overnight and attempted again using standard key fob and spare key against radar on inside of fairing and bike is totally dead.... Bike has been used and on trickle charge when not used. Have put on charge again just in case battery issue but still no joy..... Have had the bike not pick up/recognize key fob before just attempting to start it.... But then placing fob against radar as per manufacturer's instructions inside fairing usually sorts it out. The bike had been parked for a little while when I just pressed and held race on button to attempt to lock the steering.... no noise of attempting to lock steering just a yellow light flashed on display then nothing?
 

·
Registered
Joined
·
80 Posts
How many times does the light flash and I'll see if I can get my friend to look it up as he's a KTM tech.

Cheers

Daz
 

·
Registered
Joined
·
38 Posts
Discussion Starter #8
How many times does the light flash and I'll see if I can get my friend to look it up as he's a KTM tech.

Cheers

Daz
Hi Daz

Thanks for your replies. From memory yesterday I think it just came on and then went off?

Cheers
 

·
Registered
Joined
·
38 Posts
Discussion Starter #9
I wonder if their is a anti tamper theft mode.... And the bike Locks itself out?
 

·
Registered
Joined
·
17 Posts
I know most people know that already but

Put the both keys far away
Mine no light flash
if I press the race to start there is the yellow led flash once and 2 seconds after flash twice and stop

Try to bring both key close to the antenna (icône located ont he left side of the screen)
No light on my dash until I press ready to race.

And looking the voltage at the battery is an easy check

Envoyé de mon SM-G950W en utilisant Tapatalk
 

·
Registered
Joined
·
38 Posts
Discussion Starter #12
Doesn't say what 1 flash means, so worth checking.

Cheers

Daz
READY TO RACE.... Fixed!! 😂👍 Checked fuses under seat as per manufacturer's instructions. Removed and checked Fuse 1 - it had not blown. Replaced the fuse and with key fob in pocket pressed Race On Button and dash/display came to life! Crazy...... Thanks Daz.... I checked the manual also... Didn't have it to hand first of all as bike was stranded away from home address. Thanks to Soso as well.... 🙂👍
 

·
Registered
Joined
·
17 Posts
I didn't help much
But a day after I pick up my bike after 200km I stop and the bike never start back " transportation lock"
The dealer forgot to remove lock demo mode in The computer during his inspection and preparation lol

There is quite a lot of electronic on those new bike.

For the best and the worst when it's jot going good

At the end I try to enjoy the good minutes that the bike give me lol so far I love it
After put ergos seats , a windshield deflector, adventure pack, heated grip, ktm cases with linner and ktm tank bag
Now I'm thinking maybe look at puig upper deflector or habdleguard deflector not sure which one
So 4500$ cnd option later I feel better... Not my wallet lol

Envoyé de mon SM-G950W en utilisant Tapatalk
 
1 - 14 of 14 Posts
Top