KTM Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello im a new member on here. Ok so i need a little help with my smc660 - 2003.
I bought my bike as a non runner off ebay. I have repaired the engine and it wont start. I noticed the mag, or fly wheel has been removed before but without the extractor, hence damaging the magnets (ive found loads of little bits inside the stator coil plus the pickup. Any ive cleaned it all up and put silicon around the gap to stop anymore bits from coming out. My question is, will this damage to the magnet or magnets in the flywheel prevent my bike from starting??? Oh yeah, before i go i have a little advice to anyone looking to replace an oil pump in a smc660 lc4 - 2003. The pump in question is a mukuni G-185 660 99 (585.38.007.000)
When i originally stripped the engine to find out why it had seized, this oil pump had failed, stripping the plastic gear too. I found while fitting a new oil pump, as i tightened the three bolts the new oil pump tightened up, actually it wouldn't even turn. To cut a long story short on the new oil pump there is a small piece of rough cast on the side of the pump that prevents the pump from seating correctly.(it looks ok but trust me its far from it)
By the way the original oil pump have tell tail signs on the back of it, that's why the chap i bought it off had problems trying to repair it. (it took the crank out too due to lack of oil)
 

·
Registered
Joined
·
1,757 Posts
it may well be the coil/flywheel mate...

my husky would run but not charge and none of the elctrics would work. one of the studs came off the flywheel and only knocked a coil off coil off the stator and that was all the damage on it. replaced it and its all fine now. :)

could be the same thing?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Ok i will have another look at it. I forgot to mention ive tested the stator/ charging coil and the pulse generator for resistance and all seem ok. But i do not have a peek voltage adapter to test it all out fully, i was wondering if the fly wheel could be the problem. I have fuel plus a weak spark, oh and a bad leg after kicking over for hours on saturday!!!!!.....lol
Thanks for you help by the way. Id welcome any ideas at the moment
 
1 - 6 of 6 Posts
Top