KTM Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,575 Posts
Discussion Starter #1
Went to work yesterday and pressed the button to set the alarm.... went to leave last night and can't disarm the alarm. Switched on the ignition and of course triggered the alarm. Tried new battery in the fob... nothing... tried another battery also with new battery.... nothing? Battery now drained through the indicators flashing, thought I'd charge the battery see if the alarm is now dead but removed the seat and set the bastard off again :-( tried pluggin in the optimate and that doesn't seem happy and the alarm unit makes weird noises so unplugged that.

Any ideas on how to reset the thing..... booked in for Silverstone on Monday :-( need to get news tyres fitted etc and could do without this shit. I hate bikes with keys let alone alarms!!

Its the KTM badged alarm on a 2005 990.... I'm assuming factory fitted?
 

·
Registered
Joined
·
669 Posts
once the unit needs to be reset you need the RED CARD and the code number from that card. you also need a meta dealer to reset it. ( sorry not good new but thats it. you could try to rechange the battery and use the spare key? may work but I am not sure. if you dont have the red card and the reset code on the card its a new alarm or a bypass wire, again from the dealer. if it was easy to reset there would be no reason to have an alarm.)
 

·
Registered
Joined
·
293 Posts
Mine's also just started doing this or at least similar behavior (on an SMT). Just checking - been out in the rain. Seems to be the cause for mine.
 

·
Registered
Joined
·
669 Posts
A bit of a after thought. I had a simular problem with my alarm (factory fitted meta) when i first got the the bike. if its making any noise/crackling etc get it sorted fast as I was told they can and do catch fire. disconnecting the batt isn't much good as they have batt backup.
 
1 - 4 of 4 Posts
Top