KTM Owners Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
Ok i have just fitted a new clutch in my lc4 and now i can not engage gear with out it stalling. any ideas on what i may have missed or miss adjusted would be greatful.:mad::mad::confused:
 

·
Registered
Joined
·
4,119 Posts
take the clutch cover off, is the clutch pressure cap moving when you pull the clutch in
 

·
Registered
Joined
·
4,119 Posts
did you pre soak the plates in oil
 

·
Registered
Joined
·
4,119 Posts
if you did the clutch by laying the bike on its side, as I do, then there might be air in the clutch line, you might need to bleed it out with mineral fluid
 

·
Registered
Joined
·
4,119 Posts
I'M LOST THEN COZ I DON'T KNOW ANYTHING ON ADJUSTING CABLE CLUTCH SORRY, fuck cap locks sorry didn't mean to shout
 

·
Registered
Joined
·
4,119 Posts
can you not just take up slack out of the cable till the clutch don't drag
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #12 ·
ive tried the cable with slack, no slack and over tight. so im at a complete loss to what i have done. when i fitted the new clutch i made sure the steels had the sharp edges facing in, does this apply to the friction plates? do they have sharp edges??????
 

·
Registered
Joined
·
505 Posts
Iirc, I think the plate at the back of the pack is slightly larger inside diameter to fit over an o-ring? I'm on iPad so can't upload pic but hopefully you can see the different plate and o ring here:

Clutch 625 640 660 LC4 04-06

Items 9 & 17.....If ya put the wrong plate in or trap the o ring it'll stop the clutch working.....
 
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top