KTM Owners Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter #1
One good side - my bike can't get stolen by the guy riding away with it like my husband's bike did.. BECAUSE THE DAMN THING WONT START!

WTF KTM?! What is it going to do next? Bust out into flames one night?

I was trying to take it to work this morning so we could adjust the TPS. Put the key in to start it and the fuel pump sounded kinda odd. I try to start it and just get the EFI light and the key light. ... .. ... I'm NOT impressed. And yes I tried it again hoping it was just messing with me. THEN I tried my other black spare key - no go same thing.

I should have kept my '03 CBR600RR. Sure it was slow and didn't handle worth a damn but it NEVER gave me any issues!!!! ALWAYS ran and ran good!!

grrrr Now I wait until I can call KTM USA and ask them WTF? My god I wish they would take this damn bike back.
 

·
Registered
Joined
·
469 Posts
LTG, that really sound the pits to be honest. I thought i was having problems with mine until i read your tales. If it helps mine is now running sweet as a nut which i never thought it would so there is still hope for yours. Either that or trade the thing in for something else and let another dealer have the problem.
Good luck anyway
 

·
Registered
Joined
·
7,985 Posts
Problems compounded by a tech who's not very happy to work on the bike with no experience of them and you really do have a nightmare going on don't you?
 

·
Registered
Joined
·
7,201 Posts
fuel???
 

·
Registered
Joined
·
15 Posts
sorry to hear about your problem, but on a side note there are some GREAT signatures in this thread so far !!

scottishrc8 - that clip is mint !!
 

·
Registered
Joined
·
885 Posts
Did you ever check the grey blocks?? I don't want to sound like a broken record but it is a known issue with them.. (especially with the Superdukes - which have the same connector block)
 

·
Registered
Joined
·
4,848 Posts
One good side - my bike can't get stolen by the guy riding away with it like my husband's bike did.. BECAUSE THE DAMN THING WONT START!

WTF KTM?! What is it going to do next? Bust out into flames one night?

I was trying to take it to work this morning so we could adjust the TPS. Put the key in to start it and the fuel pump sounded kinda odd. I try to start it and just get the EFI light and the key light. ... .. ... I'm NOT impressed. And yes I tried it again hoping it was just messing with me. THEN I tried my other black spare key - no go same thing.

I should have kept my '03 CBR600RR. Sure it was slow and didn't handle worth a damn but it NEVER gave me any issues!!!! ALWAYS ran and ran good!!

grrrr Now I wait until I can call KTM USA and ask them WTF? My god I wish they would take this damn bike back.
i think your problem is no good dealers or somebody that can sort it out for you, because once sorted you wouldn't want anything else 17500 mile no probs so far (i do feel sorry for you though) hope you get it sorted if not go buy a boring FIREBLAND:rotflmao:
 

·
Registered
Joined
·
180 Posts
Discussion Starter #9
I'm going to cry.......
SOMEHOW it's the Immobilizer control unit - circut fault
KTM says normally thats from using the orange key (he said red but i'm pretty sure it's orange)
It has never been near the bike so i'm not too sure how that happend??? He said to check my ground wires - wtf? If it had a bad ground i'm pretty sure the headlight and crap wouldn't work as well as it does. Not too sure why that would cause the damn bike to lock up.
The fix? Resetting the damn ECU AGAIN. I want to kick someone!!!!!!!

Thankfully my boss said he'll let me take the xc-1 and laptop home with me tomorrow. Not like I have much freakin' time since I have to go to my 2nd job after I eat dinner tomorrow.


And I am going to buy another Honda... Beats the CRAP out of going through this!!!!! First paint crack on tank.. then cracked tank.. then random stalling.. and sputtering throttle that goes to unresponcive throttle while i'm riding... now total lock down.
 

·
Registered
Joined
·
3,154 Posts
dont understand why it hasnt been picked up by the dealers and sorted out on warranty. the bad earth makes perfect sense, it probably locked up coz of no power, check the grey block, open it up and check the blades, squirt some elec contact spray in there and clip it back together
 

·
Registered
Joined
·
262 Posts
Feel sorry for you LTG but find a tech who know WTF hes talking about, sounds like you have some major issue with KTM here call the head office in Austria and give em shit , it may or may not help but it may make you feel better.
 

·
Registered
Joined
·
799 Posts
Whats that stuff they go on about on the Repsol Forum, blinkerfluid...maybe try that..

Thats what happens when you say out loud your gonna sell it and get another Honda...and a white one at that...
 

·
Registered
Joined
·
180 Posts
Discussion Starter #16
lol turns out the keys somehow lost programming (No I didn't touch the orange one)

It's reprogrammed and even the throttle sounded great... maybe because it knows it's up on ebay.
 
1 - 16 of 16 Posts
Top