KTM Owners Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
2,221 Posts
Discussion Starter #1
Went out on the bike todayt for the first time since it came back fomr the dealers after getting the oil leak fixed.

The dealer also took all the slack out of the throttle cable, it never really bothered me but actually it feels much better now, all adds to the sorted feeling of the bike.

And I did the 15 min reset, never done it before, even after I fitted the Pipercross air filter (I really should have done it then) and it all adds up to making the bike feel spot on. I had been thinking it was feeling a little sluggish but that might also be to do with all the luggage I had strapped on it last time out. But today it was like a new bike, responsive, pulled like a train and the gear change was fautless.

Why didn't I do the 15 min reset before!!!!!
 

·
Registered
Joined
·
180 Posts
well congrats! Hopefully my mechanic can fit me in tomorrow to see if an ECU reset will help mine out. If not i'm probably going to get upset at KTM USA. I feel like my bike is trying to kill me. Yesterday I got into the middle of an intersection and when I twisted the throttle I got no responce. After the 3rd attempt I got a sputter then 4th it finally got the juice and got me out of the way of the car coming at me. I almost peed myself... thats the 3rd time something has happend with that bike in a BAD situation.
 

·
Registered
Joined
·
7,985 Posts
Sounds like you got a lemon rather than an orange LTG :frown:
 

·
Registered
Joined
·
324 Posts
Have you run out of fuel at anytime LilTuffGirl?....if so maybe worth replacing the fuel filter as it may have collapsed causing fuel starvation.
 

·
Registered
Joined
·
885 Posts
Liltuffgirl, That's the big grey connector, I can almost guarantee it.. Mine did the same for a while.. felt like it was cutting out, then, BANG, all the power back in again.

If you go and see your dealer, get them to check this connector (on right side, just below the tank)... Get them to make sure it's dry and all connections are good.
 

·
Registered
Joined
·
2,221 Posts
Discussion Starter #7
dear oh dear. Hope you get it sorted. The worst I've had is false neutrals approaching a corner which isn't very nice either!
 

·
Registered
Joined
·
180 Posts
I work at the dealer ;) Thats part of the reason why it's taking so long to get my bike in :( But i'm going to hopefully have him do the ECU reset first thing this morning so I can test her during lunch. Seems to only happen if she sits for a while. Actually I have NO idea when it happens since its pretty damn random.

I'll check it all over but if this doesn't fix any of it i'm going to request someone from KTM america to come try their hand at it (they aren't far away and have already said they would). If they can't fix it I guess i'll have to be "that" customer and demand a buy back. I'm PRETTY sure they don't want my family after them if this bike causes me to get injured or killed. That could have VERY EASILY happend the other day when I had no throttle! The city I work in sucks and no one pays attention.
 

·
Registered
Joined
·
1,727 Posts
if I am not mistaken, if that big gray connector is not connecting well, the FI light will come on
 

·
Registered
Joined
·
885 Posts
I had no lights coming on on mine, but the connection was obviously weak enough for the signal that should have gone to the fuel injection to not be getting the message.. However, since it was sorted, it has NEVER repeated the symptoms that are exactly as mentioned above.. It would feel like it had gone onto one cylinder and wouldn't rev, then suddenly, it would flick back into life and launch forwards (launching because you had the throttle wide open because a split second before it was doing nothing and trying to stall..)

Anyway, Liltuffgirl, you would be mad not to do the following:

Get your mechanic to check:

fuel filter (some have collapsed causing fuel flow problems)
big grey connector.. Even by just pulling it apart (it's just two halves of a big grey plug) and leaving it for a while might be enough to resolve your issues.

I doubt there's anything wrong with your ECU...
 

·
Registered
Joined
·
7,985 Posts
Sincerely hope it's something as simple as that. Not had much luck with that bike to date have you LTG?
 

·
Registered
Joined
·
180 Posts
I haven't had good luck with and liter bike.

We did the ECU reset and I road her to the store during lunch and she didn't seem like she was dropping RPMs randomly anymore.. still have a studder though but the KTM guy said we'll have to do something else to fix that. Annnddd the front tire finally came up and I was only half throttle :) so it's getting better!!

And arai is sending me parts for free that I broke on my helmet :) YAY!! Good day other than some asshole customers.
 

·
Registered
Joined
·
5,181 Posts
Lots of positives there Tuffty.:D

Keep the faith

PLC 255 days to go
 
1 - 13 of 13 Posts
Top