KTM Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

21 - 31 of 31 Posts

Registered
Joined
27 Posts
Discussion Starter #21
All sorted for the speedo. Following this wiring diagram, the colors from diagram matched up perfectly with the speed sensor itself. I just spliced into the main loom and hooked it up into a superseal connector for both the loom side and the speed sensor side. Once the new indicators arrive it should be time for an MOT :D Pictures of the usual are always on the album above.

Now am trying to decide whether to keep the front side bits that go on the headlight or get rid.

I will admit the tilt sensor fucked with me once or twice 馃槀

38719
 

Registered
Joined
154 Posts
Well done, good news! Curious though, why did you have to splice into the loom? Surely there must have been a spare wire looking for a connection there somewhere.
I have bust bits of plastic beside the headlight, not managed to find any for sale yet but not really a problem anyhow. If you get little LED indicators dont forget to get a 拢3 resistor too or they will blink too fast.
Looks like you will be up and running for when the sun arrives!
 

Registered
Joined
27 Posts
Discussion Starter #23
I nabbed indicators off wemoto so hopefully shouldn't be a problem. Although their still awaiting parts.

Also that's the weird thing, the loom doesn't seem to have the wires available to just use. I have a few theories about this

1. Cut completely to aid stealing but it's a bit of a stretch, like why cut it when you can just unplug it
2. Someone reloomed this bike but used a 2011 loom since the two wires grey with black strip and grey are sat there doing nothing. They match the 2011 wiring diagram. I tested both with no luck.
3. Am being blind as fuck haha but I've put pictures up of any stray wires.

So I just thought fuck it and tapped into the instrument connector directly. I really didnt wanna strip the entire loom down looking for the wires. Maybe if I get hold of a decent loom and the right year I'll reloom it properly in the future but for now I'll just enjoy it for the summer me thinks
 

Registered
Joined
154 Posts
Screw it... it works... job done :)
Its snowing like a bastard here today, looks like you will have an eternity to sort the sucker out before the sun arrives!
 

Registered
Joined
27 Posts
Discussion Starter #25
aiye am not tryna overthink it. it was here and all, its like -3 atm. i really wanna go for a quick round the block but fook me its cold 馃槀

turns out front needs new discs since one is warped, so am like fuck it, i guess both discs and pads are being done.

i also have non-standard brembos, their not oem, the pads are these

 

Registered
Joined
154 Posts
aiye am not tryna overthink it. it was here and all, its like -3 atm. i really wanna go for a quick round the block but fook me its cold 馃槀

turns out front needs new discs since one is warped, so am like fuck it, i guess both discs and pads are being done.

i also have non-standard brembos, their not oem, the pads are these

EBC HH are the way to go... good initial bite and never fade! I only use them on all my bikes, and they make a lovely zingging sound :)
 

Registered
Joined
27 Posts
Discussion Starter #29
So ended up using led relay. Much tidier imo


Also bled all the brakes and replaced fluid. Next up to replacing the warped disc because even after bleeding it's still causing fade whenever the disc is at the fucked position 馃槀

shes also still rocketing to the max temp. Coolant is full, could this be due to a dodgy thermostat? i haven't checked water pump just yet but next suspect.

or could it be a mix of the Akra map mixed with stock exhausts?

either way new vid is up of how shes looking.

got a LC4 black fender which doesn't fit so ill have to figure something out
 

Registered
Joined
27 Posts
Discussion Starter #31
the last little niggle, well aside from a nice exhaust, is the either bent handlebars or maybe fucked top yoke.

the forks/wheel/top yoke are all straight, but the clamp where the bar goes isn't.

ill have to open here up and take a look, could just be bent bolts but i doubt it.
 
21 - 31 of 31 Posts
Top