KTM Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 13 of 13 Posts

·
Registered
Joined
·
311 Posts
Discussion Starter #1
I've just changed the oil & filter on my 2018 SDR, but can't for the life of me reset the service interval mileage and date.

I get to the screen where the miles and date are showing, and have pressed every button in turn on the bars, also the up & down button at the same time, but I get no opportunity to input a new date or a new mileage figure.

Has anyone got any suggestions?
 

·
Registered
1290 Superduke R
Joined
·
419 Posts
On the gen 1 you have to push both up and down arrows together and keep them held for what seems like ages before the service reset comes up.

Don't know if the gen 2 is the same by on the 1's the mileage interval is in kms so you have to convert.
 

·
Registered
Joined
·
311 Posts
Discussion Starter #3
OK, I will go back and try again.

I only pushed the up/down buttons for maybe 10 seconds
 

·
Registered
Joined
·
311 Posts
Discussion Starter #4
Damned if I know what's going on - I can't even get to the page where the mileage/date info is now.
I flick through the menu & get to the SERVICE screen - press SET and bugger all happens.
 

·
Premium Member
Joined
·
834 Posts
Try this.

 

·
Registered
Joined
·
48 Posts
Yes the gen 2 is the same, hold the up and down buttons. I think you have to be in the setting menu when you do it, can't remember. But it works.
 

·
Registered
Joined
·
311 Posts
Discussion Starter #7
That's the advice I followed, Camac, but the first time I tried it, it didn't work, and the second time I tried, for some reason my screen would not go past SETTINGS and into the section where the alterations can be made.

Then I gave up for the day.
 

·
Registered
Joined
·
311 Posts
Discussion Starter #9
Thanks for the vid link. I can't see that I'm doing anything differently - I scroll through to the settings menu, hit set, scroll through to this screen.......



Then nothing I do makes any difference. I hold the up & down arrows for 60 seconds, but still nothing. Tried the left and right arrows out of desperation - nothing. Hit the set button - nothing.

I might have to give up and take it to a dealer, but that will be very disappointing. I can't understand why my dash won't react like everyone else, or what I'm doing wrong.
 

·
Registered
Joined
·
311 Posts
Discussion Starter #10
Cancel that - I watched the vid one more time after my failure, and it seems I went to far into the menu before I hit the up/down buttons.

I see now that you hit them from the settings screen, not the service interval screen.

Thanks for all of your help - I'm obviously just a numpty.
 

·
Premium Member
Joined
·
834 Posts
Cancel that - I watched the vid one more time after my failure, and it seems I went to far into the menu before I hit the up/down buttons.

I see now that you hit them from the settings screen, not the service interval screen.

Thanks for all of your help - I'm obviously just a numpty.
Next time mate, get a teenager to help. That`s what I do. 😂
 

·
Registered
Joined
·
311 Posts
Discussion Starter #12
Sound advice.
 

·
Registered
Joined
·
17,248 Posts
Cancel that - I watched the vid one more time after my failure, and it seems I went to far into the menu before I hit the up/down buttons.

I see now that you hit them from the settings screen, not the service interval screen.

Thanks for all of your help - I'm obviously just a numpty.
I was the same, it took me bloody ages. I still don't know how I did it.
 
1 - 13 of 13 Posts
Top