KTM Owners Forum banner

1 - 20 of 20 Posts

·
Premium Member
Joined
·
489 Posts
Discussion Starter #1
All,

Just fitted one of the KTM 320MM Wavy Discs to my SMC 625.

Since fitting it the speedo impulse which picks up the front wheel turning and activates the speedo itself has stopped working altogether. It also doesn't work when out on the road either, which could cause me a problem :).

The wires look fine, its all connected as it was before i swapped the disc out, so why now, all of a sudden has it stopped beeping working?

Has anyone experienced this problem themselves, or if not, any pointers please as to where I need to start looking??

Should the sensor be xx mm close to the disc itself. Are there any guidelines from KTM as the 54 page manual i have is shite, in a word.

Thanks in advance

WB :(
 

·
Premium Member
Joined
·
489 Posts
Discussion Starter #3
Theres nowt on the old disc at all, which is the first thing that I did look for.

Funny how on this discs the ornage carrier is alloy so I'm wondering if this is the reason why it doesnt work, and there is actually a hole type bracket which makes me further wonder if this is where on this disc you after to fit some after market magnet, as the original disc is steel and the body of the disc is steel so maybe thats the answer.

I'll call the KTM dealership tomorrow to ask, but thanks for the response anyway, as at least it kinda lines up with what i was thinking.

Cheers

WB
 

·
Registered
Joined
·
526 Posts
Don't know if it's the same but did you change the screws that hold the disc on at the same time, on my 690 I think the screws are magnetic which is what gets picked up I think so if it's the same and you used normal ones then it could be that (or I could be well off the mark :D ) 59009062023
 

·
Registered
Joined
·
7,831 Posts
there should be a magnet in one of the disc bobbins
 

·
Premium Member
Joined
·
489 Posts
Discussion Starter #6
I fitted 6 new bolts as part of the new disc swapout -all supplied by the KTM dealer - so they should be the right ones - but I'll check that as well.

No magnet in the disc bobbins - although, forgive my ignorance - but what do u mean by bobbin.

The disc is on the Gear 4 website - Part Number - 58409060200 - No mention there of any other items needed - just strange how it all worked correctly before - and now after just swapping a simple disc the bloody thing stops working.

Thanks for the nudge. I'll take a closer look in a minute and then also speak to the dealer in the morning.

Cheers

WB
 

·
Premium Member
Joined
·
489 Posts
Discussion Starter #7
Magnet off the old disc doesn't fit the new disc - hence why the sensor isn't working....Doh!!

How come the bloody old magnet wont fit the new disc - u would have thought the dealer would list both items - in my opinion - bet its a stock item from Austria

Thanks for everyones input - very much appreciated...

WB
 

·
Premium Member
Joined
·
31,431 Posts
You dont need special bolts cos your bike has the M8 threaded sensor, not the flat sensor that is attached to the forkleg by 2 screws.
There is a hole in the disc to suit the magnet....
Its at 8 o'clock on this image
 

·
Premium Member
Joined
·
489 Posts
Discussion Starter #13
Thanks,

I removed the old magnet and had to glue it on to the new disc as the length of the body of the magnet wasn't long enough to refit the circlip.

Unfortunatley, it still doesn't work.

I'll order a new magnet and sensor on Monday to be on the safe side, just weird how it all worked mighty fine until i swapped the disc over - bloody frustrating.

Anything else i may need to check?

Cheers

WB :)
 

·
Premium Member
Joined
·
489 Posts
Discussion Starter #14
My disc is different to this, the eye where the magnet goes is much more of a raised piece of metal, circular for the magnet, but all the same different to the one in the picture, perhaps thats why it don't work...

It looks like part number 58609060000 , whereby there is a raised section if you look at the picture on the Gear 4 website. Its a 320mm Orange disc, just has this other piece that I'm assuming is for the magnet

Any ideas Kev??

Cheers

WB



You dont need special bolts cos your bike has the M8 threaded sensor, not the flat sensor that is attached to the forkleg by 2 screws.
There is a hole in the disc to suit the magnet....
Its at 8 o'clock on this image
 

·
Premium Member
Joined
·
31,431 Posts
Get the longer magnet 58214069050 SENSOR MAGNET ADVENTURE 01 and
471009104 CIRCLIP DIN0471- 9X1 INOX


make sure your sensor lines up with the magnet ;)
 

·
Registered
Joined
·
7,831 Posts
Get the longer magnet 58214069050 SENSOR MAGNET ADVENTURE 01 and
471009104 CIRCLIP DIN0471- 9X1 INOX


make sure your sensor lines up with the magnet ;)
Kev, aint there a certan gap between the pickup n magnet.....i done mine by trial n error tho to get the gap
 

·
Premium Member
Joined
·
489 Posts
Discussion Starter #17
Trouble is, where the raised piece is for the magnet is about 2-3cm away from where it should be aligned to as it passes the sensor on the bracket just off the front brake caliper.

On the old std disc it passed straight by it, so obviously activated it even when u just roll the bike in the garage - as you would expect it to...

Fun convo with the KTM dealer on Monday - deep joy...looks really good as well unless i do try and opt for a few magetic bolts that hold the disc to the wheel - maybe that will do the job???

Cheers for your input, mucho apprecio

WB :)
 

·
Premium Member
Joined
·
31,431 Posts
You only need one magnet. If you fit two your speedo will read twice as fast as it should!

Which brake bracket are you using?
 

·
Registered
Joined
·
1,253 Posts
I had the same issue when I had installed my wavey disc but I saw that the magnet and the sensor aren't line up so I added a small bracket and fixed that issue.. :)
 

·
Premium Member
Joined
·
489 Posts
Discussion Starter #20
Thanks,

What i intend to do is take the bracket off and drill a new hole so that the magnet and the new hole in the bracket are aligned....

Much appreciated - it just took a time to get my poor old head around it - Doh!!!!

WB :)
 
1 - 20 of 20 Posts
Top