KTM Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Evening all - I took delivery of my 17 SA r on Saturday. To cut a long story as short as I can make it, the bike has been delivered 3 weeks late due to the dealer discovering it needed the TFT replacing the day before I should have been bringing it home at the start of the month. Was delivered on Saturday but due to it being my kids birthday and me therefore not having time to have a fettle with it the bike was wheeled off the van and straight into the garage with little more than a quick look around it to make sure no marks or dents had appeared over the past 3 weeks. Tonight I've popped out to the garage to have a poke about and start to get to know the bike...and I'm convinced the dealer has messed up when fitting the new screen and reflashing the ECU (which I'm assuming they have to do when replacing the TFT). I've got no "My Ride" section on the main menu...and looking at a few vid's online that's where it should be. I also only have 3 ride modes...sport, street, and rain. No off-road...which is standard according to everything I can find online. Is there a dongle that needs plugging in under the seat for off-road or should it just be there in the ride mode menu (as I believe to be the case)?

Thanks in advance

Jonesy
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
They might have loaded the S Software.

Have you not thought of calling them?

That's where I would start ;-)
It's a fair point. I've emailed them last night. I will be calling when I get a minute at work today...was just looking for a steer from somebody who had one.

I thought it might have been done with the S software...but then that doesn't explain the missing My Ride stuff. I'll post when I get some info...
 

·
Registered
Joined
·
582 Posts
I’m sorry I can’t help. These new bikes have gone to far for me, reliant on dealer for this, dealer for that. Everything has a wire going to it. My Technology curve stopped with my ktm 1190r. Only went into dealer for first service after that do everything in my garage. Does everything I ask of it. Never had any trouble, mind I still have to put a key in a lock to start it and fill it with fuel!
 

·
Registered
Joined
·
34 Posts
Discussion Starter #5
I’m sorry I can’t help. These new bikes have gone to far for me, reliant on dealer for this, dealer for that. Everything has a wire going to it. My Technology curve stopped with my ktm 1190r. Only went into dealer for first service after that do everything in my garage. Does everything I ask of it. Never had any trouble, mind I still have to put a key in a lock to start it and fill it with fuel!
I'm starting to feel like getting something with a little less electrical wizardry would have been a wise choice...and no worse a bike I bet
 

·
Registered
Joined
·
1,340 Posts
I thought it might have been done with the S software...but then that doesn't explain the missing My Ride stuff. I'll post when I get some info...
This is enabled by an Unlock code, again, when flashing the system it needs to be re-instated.

Call the dealer and I am sure they will know what to do - but as their miles away you might have a bit of grief getting it sorted without an extended ride-out.
 

·
Registered
Joined
·
4,033 Posts
Sounds fucked to me
 
1 - 7 of 7 Posts
Top